Start a new topic

Samsung devices not connecting to link on Verizon

Has anyone else noticed that the Link Reader, will no longer connect to Samsung devices since Verizon's last update?

My headsets and external speakers still work, buy my fitness tracker and the Link Reader will not.

I am using a Note 4

Best Answer

Our product team has provided the following update for you:

“The ESU <emergency software update> schedule is on works with VZW....we do have a fix coming in an ESU and as soon as we have the schedule, we will share with you.”

1 person has this question

I'm having the same issue here, same phone as well.  I am getting nowhere with support to this point.  It's very frustrating.

Have you received any assistance with this?  I am going in circles with support, they keep asking me to try and connect over and over.  it just keeps saying it is trying to connect but never does.  I've had 3 replies and they have all asked me to connect and then re-report the problem.  Horrible experience so far.  I could have picked up a rock if I wanted a paper weight.  At this point I just want a refund and to return this.

nothing at this point, this maybe an issue caused by Verizon's update.  But I have not seen Verizon post anything on their Note 4 section on their forums

We are investigating the root cause. In the meantime, you can work around the problem: just enable GPS location in Android settings during pairing. Once pairing is completed, you can re-disable GPS in Android settings if preferred.

I have it enabled and it still will not connect.

The work around does not work

I'm on about day 10 of dealing with customer service/runaround on this. I've had the link for 1 month and have not been able to use it aside from 1 hole the second day I had it before it wouldn't connect anymore. I just want a refund at this point.

I have had the unit for about two months it was working fine but now I cannot get it to connect. I got two days of response from them a week ago then they went dark. I am SO frustrated I had to scan manually with NFC this weekend. I too have told them I want my money back that's when email stopped.

I agree, it's not what I paid for and I'm done.

Started trying to pair at 11:55 am it is now 1:30 pm everything is enabled it shows the devices but will never connect. I have reset the device, phone and hit "search again" about sixty times still no connection. It looks for my device, finds it immediately but will never connect.

I did try an old LG after twenty tries it connected but this does me no good since that phone is not in use. It obviously has something to do with Note 4 update but they are not giving us any information. Poor customer service!!!!

1 person likes this
We confirmed the problem is caused by Samsung's latest update. This is not limited to Golf Pad LINK, other types of devices are affected too. We contacted Samsung about this and will follow up as soon as they provide more information. We are also investigating if there is a way to work around that problem on our side. In the meantime, please try the following solution provided by Samsung support:
Can confirm this did not work with my device. When will we be offered a return/refund. I've owned this for a month and it hasn't worked.

I too just did this Samsung clear of cache and have tried to add the piece back in thirty times with no connection. I would like a refund at this point I am moving on to PIQ to give it a try,

@All - our team is working on this issue - both with Samsung and internally. The Samsung update impacted more than just Golf Pad - many other applications were negatively impacted. If you are a Kickstarter backer, please note, we aren't able to provide refunds, but our team WILL ensure your LINK is working correctly just as soon as possible. Your support is important to us. We understand the frustration you are experiencing and are working around the clock to handle the issue. If you hae an URGENT question or concern, feel free to email me directly and I will personally respond as soon as possible. Our support queue is backed up.

Login or Signup to post a comment