Start a new topic

Pebble Watch stopped contecting

After the latest update to Golf Pad, the app no longer connects to my pebble watch. On Thursday I played a round with no problems at all - on Monday I load up the course on my phone but there is nothing on my watch. My husband has the same problem.

2 people have this question

The team delivered! For those of you who want to try to download an older version to try to restore Pebble/ Golf Pad compatibility. Here is a link to the file: 

You  will need to uninstall the current version from Google Play first and disable automatic updates so this version is not overwritten. You may need to enable installing app from unknown sources: You will miss out on all future app updates. We strongly encourage you to get a supported watch instead. Finally, this build may or may not work with Pebble and we can’t provide any support assistance if something does not work.
Oh, thank you guys! So happy. Now I can use my fav app again on my fav watch :-)) Maybe put this in your general Pebble instructions too, to avoid confusing?
Hey redirecting a dead thread to offer help. I am a software engineer and love two things in life, GolfPad and Pebble watch. I would be willing to do the development to allow Pebble to work on GolfPad. I am sure we could work out some way to open source that feature without opening up all your code. Or an NDA or something. Short of that, have you looked at the BangleJS watches. I have made several apps for those too. I could port the support to that

Hi Brant - Thank you for being such an avid supporter. :) 

Update from the team:

"We appreciate the offer, but open-sourcing a portion of our codebase or setting up the NDA and access is not feasible. We love Pebble too, but it’s time to move on to the newer watches. They come with many new cool features that were not possible on Pebble, and we’re focusing our efforts on making our watch apps even better. "

Since the last Android update, the app often lost connecting to my Pebble. I tried to reinstall from the APK file, but now my Pixel says App cannot be installed on your device HELP PLEASE
The very much appreciated provided APK can no longer be installed on my Pixel 5! Is this really the end for my beloved Pebble/Golfpad combination? Such a waste to throw away a good working app and/or device, for no apparent reason. Silly world we live in.

Thanks for sharing your feelings. I'm sorry to hear the APK no longer works for you. I'll let the team know, but I don't think there is anything additional we can do. If I find otherwise, I will post here. 

Could you please provide us more details:

1. Android version on your Pixel 5 phone

2. What exactly happens when you are trying to install apk?

I have Android Version 13 from October 5th.

When I try to install the APK by clicking on it it just says "You can not install the app on your device"

Well I concluded it is end of the line so I ordered a Garmin Vivoactive 4. But I now found out that Golfpad does not support Garmin. Pff.
Any chance that this will change in the future?

I had similar experience, but managed to give it the appropriate permissions and it's working, I believe to do with Android 13 withdrawing native support for 32 bit apps.

It worked before. I had the Golfpad APK installed, but after the last Android update connection kept getting lost while golfing and trying to reinstall the APK failed: with "You can not install the app on your device"
Where did you set these permissions exactly?


I was also installing the Pebble/Rebble side of things at the same time, so an awful lot of trying this and that, so just in case I've mixed things up, perhaps the GolfPadGPS Team could confirm whether the older version we are using "GolfPad_15.79.3_Pebble.apk" is 32 or 64 Bit as it doesn't contain the "lib" folder that various Internet articles point to as an indicator.


Login or Signup to post a comment