New Auto-Advance Algorithm for Android

New in Android Version 14.5


Update your app for a new hole auto-advance algorithm. This new algorithm uses artificial intelligence system backed by Google's TensorFlow framework to pick the right hole for recorded shots. You should see improved hole assignment when using Golf Pad LINK or TAGS. Choose between new and old algorithm in settings / auto-advance. 


Let us know what you think! This is a big feature update and we need everyone's feedback. If you see any issues, have questions or comments, lets us know.


We should have an iPhone release in the next several weeks as well!


2 people like this

Thanks Doug - unfortunately, I don't see the update as being available. I just checked my version and I'm at 14.5 with no updates available. I went to the Play Store and the version on there is also 14.5. I uninstalled the app hoping that if I installed it fresh that it would get the latest version, but I still ended up with 14.5. I am playing today in a few hours so hopefully it'll update soon. If not, I know I just need to swipe up on my watch to advance the hole. Thanks for responding - have a great day!!

1 person likes this

We recently released an update to the fixed auto advance feature: Android version 14.5.3. - which is available now. 

Played two days now with 14.5.3 and link worked perfectly for registering hole advance and putts. My experience is that the update had solved my earlier issues. Thanks

OnePlus2, OxygenOS 3.6.0, Android 6.0.1.  Same thing.  New algorithm not advancing to next hole.  Previously no issue on same course.  5 rounds at the same 9 hole track since Saturday, same behaviour.  On 5 of the holes Driver is in use after Putter.


Maybe if after TensorFlow is done and a new hole is not detected the club selection could be run through the old algorithm as a fall back?

J.S. Walsh - we are sharing your comments and feedback with the development team. Thank you.

I had the same issue last night.  Never once did it auto-advance, and I ended up with putter then driver, etc. and had to move the strokes to the next hole, when I forgot to manually advance.  For now, I'm changing back to the old 'auto-advance'.

Using Galaxy S7 (G930V) Android 7.0 security patch Level: August 1st, 2017.


FYI:  the link above in your post only takes me to the 'log in page', and after I log in, goes back to the home page for the FAQ...then I can click your post again, click the link and right back to the log-in page.  (Thus why I'm making the comment here, instead of wherever your link would lead.  


Still very happy with the product, it will only get better when this feature starts working as well.

I also played a round Saturday and the new algorithm worked flawlessly... I would say that it is fixed. Registered all shots, putts went where they should and auto advance was spot on. Now if we could just get that on off button to have a little bit of a delay in turning it off so that it doesn't get turned off accidentally that would be great!


Great Job!

I just used it again, this time on the old algorithm.  Same behaviour, it did not advance once to the next hole on its own.  This time it may be related to the fact that it didn't record any putts, despite giving me the positive feedback associated with a successful scan.  No putts registered.  If I manually put in the putts, it still did not auto advance to the next hole when the driver (or 3W, 3H, 4I) were next used.

OK - went and played today with the old algorithm and what everyone said earlier is true. Putts do not register with the TAGS and the holes do not advance automatically. Switched back to the new algorithm and putts will register with TAGS but the holes do not auto advance. My question is if the old algorithm used to work, why does it not work now? Did something in the old algorithm get changed? If so, you guys might as well get rid of that option to use it because it is worse than the new algorithm now.

I was not aware of the update and didn't notice that I was set to new.  I have always had minor trouble with seeing shots recorded on holes that I haven't played yet but just yesterday I was on my third hole having played maybe a dozen shots or so when I noticed that my scorecard looked like it had been assigned random shots...a shot here ....another there...a half dozens shots scattered around the holes on the card.  So I came to the forum and read about auto-advance.  I don't know if this is related because it's just not skipping (advancing) to the next hole.  They were randomly assigned or so it appeared.  I've set it back to old to see what happens my next round.

Hi Jon, I had that problem myself and wrote a support ticket about 2 weeks ago about the random assigning of shots all over the place. Support said that they were working on it but nothing yet. I played today using the old algorithm and now I have the problem of not registering putts and not auto advancing at all. I just switched the Link off mid round today and went back to just using the Tags just to finish the round. Right now the Link is just becoming to un-reliable requiring to much phone interaction while I play which in my case is a no no..

 

Douglas Smith,

Here here.  I went with the link system to avoid having to interact with my phone on every shot using apps I preferred to this one which did not have a hardware solution.  I'm disappointed at this point to say that I feel I have to use my phone too much with this solution.  My playing partners, many of who are of older generations, are noticing this.  I'm having to all too frequently check that this is working when with other products without the tag or link solution which relied on phone GPS I could use discretely.  I have inquired about returning this product, just inside the 30 day window because of this and have not received a satisfactory response.


All of that said, I am an application developer with almost 20 years of experience in all phases of the SDLC.  I'm also currently a consultant for Differential GPS and RFID based solutions in the shipping and thus I can understand this pain probably better than most end users.  To that end, thought I'm a paying user, I would like to see something like this succeed so I'm probably more patient than most when it comes to end user QA.



I know that I should have mentioned that I don't have a LINK and am using simply NFC tags.  However I was going to ask if it was thought that a LINK could help the issue.  I guess not.

I am having the same experience as JSW above. Not advancing for either algorithm when driving on the next hole and putts not being registered on a consistent 100 per cent.
Login or Signup to post a comment