Start a new topic

Link Wont Turn On Any Longer (2)

I experience the same issues as Michael but could not find a way to continue that topic.


I have used the Link for scoring through some 10 rounds. It's mostly working, but I've experienced some notable bugs (most annoying is losing connection, uable to re-connect, "reboot" and then the 10-15 minute or so wait to have it find some satellites. (How about using the phone to give it a start position?)


Oh well, last weekend I was playing a round when I suddenly lost connection to Link. I tried a restart but to no avail. I tried to charge it with a portable battery, the orange light turned on but the device did not when I later pressed the on/off. I lost some valuable "mental health" while struggling with technical issues, but managed to use my phone on the last stint.


Later I came home and forgot about it, but now I'm playing again tomorrow and when I tried to charge the Link it starts to vibrate and stays that way. The orange light is lit but it just keeps buzzing and I guess it's not charging very much. The reset "button" is not doing anything what I can see.


I bought the Link through the Kickstarter campaign and so far it's not meeting my expectations. As an $200+ upgrade to barely replace my phone as a NFC reader it's just not worth it. I upgraded firmware about a month ago an will gladly do it again if I can and if that is a solution to my problem.


I'll open a support ticket if that is what's next.


Btw, your site seems to have an invalid SSL certificate (using freshdesk.com)?


Okay, update!


After having the Link attached to a charger for couple of hours, vibrating all the time, I tried removing and inserting the charging cable a couple of times. Then suddenly the device stopped buzzing with the cable attached. I kept it that way and waited for another two three hours and, voila, the device turned on. 


So, I guess that most of my problems is/have been related to battery (drain/charging). After the device turned on and connected to my phone I tried to update the firmware but had some trouble. It failed four times after approx. 50% done, until I removed the charger cable. Coincidence?


Anyway, I now have successfully updated it to firmware 4 and played a full round yesterday without any problems. I can even say it helped me play a nice 82.


So, no support ticket needed.



Tobias - thank  you for sharing and I'm glad it all worked out. Firmware 4 should correct any lingering issues with LINK that a few users were seeing. Keep us posted. Great job on your round!

Login or Signup to post a comment