Start a new topic
Answered

Link Won't Turn On Any Longer

My Link unit was working wonderfully for quite a while.  I came back to use it again today after a couple weeks without playing and now it doesn't want to turn on.  The orange light is on when it's plugged in to charge and sometimes I can feel it vibrating very lightly when it's plugged in which doesn't seem right.  At this point, it's been on the charger long enough for a full charge but nothing happens when I unplug it and try to turn it on.  I've tried the reset port a couple times too with no luck.  


Anyone else run into this?  My unit is barely two months old...


Best Answer

Thanks for posting and providing those details. A few things I suggest trying:


1. Try a reset of the unit. In most cases, reset fixes any unusual issues.

2. Try a deep charge after the reset.


NOTE: complete battery discharge may significantly worsen battery capacity or render it non-operational. Please be sure to charge LINK before your first round and re-charge every time you finish playing. If you are storing a reader for an extended period of time (e.g. off-season), please fully charge before putting to storage and re-charge every 3 months if storing longer than that.


If these steps don't resolve the issue, please create a support ticket.


Answer

Thanks for posting and providing those details. A few things I suggest trying:


1. Try a reset of the unit. In most cases, reset fixes any unusual issues.

2. Try a deep charge after the reset.


NOTE: complete battery discharge may significantly worsen battery capacity or render it non-operational. Please be sure to charge LINK before your first round and re-charge every time you finish playing. If you are storing a reader for an extended period of time (e.g. off-season), please fully charge before putting to storage and re-charge every 3 months if storing longer than that.


If these steps don't resolve the issue, please create a support ticket.

I've tried a deep charge and still no life.  I'll open a ticket.